AppPerfect Software License Agreement
IMPORTANT: READ THIS AGREEMENT CAREFULLY BEFORE YOU INSTALL, COPY,
DOWNLOAD OR USE THE SOFTWARE ACCOMPANYING THIS PACKAGE
This AppPerfect Software License Agreement "ASLA" is a legal agreement between
"You" (either an individual or a single entity) and AppPerfect Corporation (referred herein as
"AppPerfect") for the AppPerfect software products and printed and/or electronic
documentation accompanying this ASLA (collectively referred herein as "SOFTWARE").
By installing, copying, downloading or using the SOFTWARE, You agree to be bound by the
terms of this ASLA. If You do not agree with all the terms of this ASLA, AppPerfect is
unwilling to license the SOFTWARE to You. In such an event, You may not install, copy,
download or use the SOFTWARE and You must return to AppPerfect the complete
SOFTWARE package, including the disks and printed materials or if you downloaded the
SOFTWARE, notify AppPerfect in writing that You have de-installed the SOFTWARE within
thirty (30) days of receipt for a refund of the purchase price.
1. LICENSE.
1.1 Grant. Subject to the terms and conditions of this ASLA, AppPerfect hereby grants to You
a limited, non-exclusive, non-transferable license to use the SOFTWARE for the authorized
use for which You have paid AppPerfect a license fee. This SOFTWARE is licensed for use,
not sold. AppPerfect and its suppliers retain all rights in the SOFTWARE.
1.2 Mechanism: The AppPerfect Java Unit Test, AppPerfect Java Code Test, AppPerfect
Java Profiler, AppPerfect Web Test, AppPerfect Load Test and AppPerfect App Test products
are licensed for installation on a single client machine and for use by a single user. The
AppPerfect Test Manager and AppPerfect Agentless Monitor Server is licensed for the
machines on which it is installed. AppPerfect Agentless Monitor is licensed for each device
(as defined by the SOFTWARE ) that is monitored.
1.3 Term. The license granted herein begins upon installation, copying, downloading or use of
the SOFTWARE and continues in perpetuity unless sooner terminated. Without prejudice to
any other rights, AppPerfect may terminate this ASLA if You fail to comply with the terms and
conditions of this ASLA.
1.4 No Copies. Except as expressly allowed by the terms of this license, You shall not copy or
modify any portion of the SOFTWARE other than that You may make one (1) copy of the
computer program portion of the SOFTWARE solely for archival purposes.
1.5 Other Limitations. You shall not rent, lease, loan, sell or otherwise distribute the
SOFTWARE or use the SOFTWARE as an application service provider, as a service bureau,

or in a fee-generating service provided to third parties. You shall not reverse engineer,
decompile or otherwise attempt to derive the source code for the SOFTWARE.
2. CONFIDENTIALITY; OWNERSHIP.
2.1 Title and Ownership. All titles, ownership rights, and copyrights and other intellectual
property rights in the SOFTWARE shall remain in AppPerfect and/or its suppliers. You
acknowledge such ownership and intellectual property rights and will not take any action to
jeopardize, limit or interfere in any manner with AppPerfect's or its suppliers' ownership of or
rights with respect to the SOFTWARE. The SOFTWARE is protected by copyright and other
intellectual property laws and by international treaties. Nothing in this license shall be
construed as a grant in or a transfer of any proprietary rights. This SOFTWARE is licensed for
user, not sold.
2.2 Proprietary Information. You agree that the SOFTWARE and all computer code,
inventions, algorithms, know-how and ideas embodied in or by the SOFTWARE and all other
business, technical and financial information You obtain from AppPerfect, whether designated
confidential or not (hereinafter referred to as "Proprietary Information") are the confidential
property of AppPerfect. You also agree that any expression of AppPerfect's findings,
analyses, conclusions, opinions, recommendations, ideas, techniques, know-how, designs,
programs, enhancements, SOFTWARE, and other technical information provided to You by
AppPerfect in the course of performing consulting, training, maintenance or other services
related to the SOFTWARE are the Proprietary Information of AppPerfect and are licensed to
You, pursuant to this ASLA.
2.3 Non-Disclosure. You agree to keep the Proprietary Information in a secure place, under
access and use restrictions designed to prevent disclosure of the Proprietary Information to
unauthorized persons and to instruct Your personnel to keep the Proprietary Information
confidential.
2.4 Breach. You agree that any disclosure of the Proprietary Information to a Third Party
other than in accordance with the terms of this ASLA constitutes a material breach of this
ASLA and will terminate the license granted by this ASLA.
2.5 Injunctive Relief. You further agree that You will be liable for all damages to AppPerfect
that result from any wrongful disclosure of the Proprietary Information to any Third Party or
any breach of this ASLA. You acknowledge that such wrongful disclosure or breach could
cause irreparable injury that cannot be compensated by monetary damages and that
injunctive or other equitable relief may be appropriate.
3. PRODUCT MAINTENANCE.
You understand and agree that AppPerfect may provide updates to the SOFTWARE from
time to time but AppPerfect shall have no obligation to provide maintenance or updates to

You for SOFTWARE licensed under this ASLA.
4. DISCLAIMER OF WARRANTY AND LIABILITY.
4.1 THE SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. TO
THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, APPPERFECT FURTHER
DISCLAIMS ALL WARRANTIES, INCLUDING WITHOUT LIMITATION ANY IMPLIED
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. THE ENTIRE RISK ARISING OUT OF THE USE OR
PERFORMANCE OF THE PRODUCT AND DOCUMENTATION REMAINS WITH YOU, THE
LICENSEE.
4.2 TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT
SHALL APPPERFECT OR ITS SUPPLIERS BE LIABLE FOR ANY CONSEQUENTIAL,
INCIDENTAL, DIRECT, INDIRECT, SPECIAL, PUNITIVE, OR OTHER DAMAGES
WHATSOEVER (INCLUDING, WITHOUT IMITATION, DAMAGES FOR LOSS OF
BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION,
OR OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE
THE PRODUCT OR DOCUMENTATION, EVEN IF APPPERFECT HAS BEEN ADVISED OF
THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES/JURISDICTIONS DO
NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR
INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.
5. TERMINATION.
5.1 Basis for Termination. AppPerfect may terminate this ASLA if You commit a material
breach of this ASLA
5.2 Obligations Upon Termination. Upon termination of this ASLA, You will immediately
destroy or return to AppPerfect all SOFTWARE and Proprietary Information in Your
possession.
5.3 Effect of Termination. The following provisions shall survive termination of this ASLA: 2, 4,
5.2, 5.3, and 6.
6. GENERAL TERMS AND CONDITIONS.
6.1 Severability. If any provision of this ASLA is found by any court of competent jurisdiction
to be invalid, then the remaining provisions shall nevertheless remain in full force and effect.
6.2 Choice of Law and Venue. This ASLA shall be governed by and construed under the laws
of the State of California without regard to conflicts of laws or provisions thereof, and without
regard to the United Nations Convention on Contracts for the International Sale of Goods.
You agree that the federal and state courts within Santa Clara County, California shall have

exclusive jurisdiction to adjudicate any dispute arising out of this ASLA.
6.3 Complete Agreement. This ASLA is the complete and exclusive statement of the mutual
understanding of the parties and that it supersedes and cancels all previous written and oral
agreements and communications relating to the subject matter of this ASLA. AppPerfect
disclaims all preprinted terms of any purchase order or other written instrument submitted by
You.
6.4 No Modification. You agree that this ASLA can be modified only by a written agreement
duly executed by persons authorized to execute agreements on behalf of the parties hereto.
6.5 No Waiver. You agree that any failure or delay to exercise or any partial exercise of any
right, power, or privilege hereunder by AppPerfect shall not operate as a waiver.
6.6 Attorneys' Fees. If any legal action is necessary to enforce the terms of this ASLA, the
prevailing party shall be entitled to reasonable attorneys' fees and costs in addition to any
other relief to which that party may be entitled.
6.7 Export Laws. You shall comply with all then current export laws and regulations of the U.
S. Government and the government of the country in which You receive delivery of the
SOFTWARE, which pertain to the SOFTWARE. You may not install the SOFTWARE outside
of the country to which the SOFTWARE was initially shipped.
7. U.S. GOVERNMENT RESTRICTED RIGHTS.
The SOFTWARE, including related documentation, is provided with Restricted Rights. The
use, duplication or disclosure by the U.S. Government is subject to restrictions as set forth in
this ASLA, and in the applicable provisions of subparagraph (c)(1)(ii) of the Rights in
Technical Data and Computer Software clause DFARS 252.227-7013, or subparagraphs (c)
(1) and (2) of the Commercial Computer Software - Restricted Rights at 48 CFR 52.227-19.
The manufacturer is AppPerfect Corporation, 11651 Timber Spring Court, Cupertino, CA
95014.
Should you have any questions concerning this ASLA, or if You desire to contact AppPerfect
for any reason, please write:
AppPerfect Corporation, 11651 Timber Spring Court, Cupertino, CA 95014
Acknowledgement of Third Party Software
This AppPerfect software contains certain third party software as listed below which are
acknowledged here. These are open source software for which you may obtain source and
binaries from the URL listed next to the software.
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Apache Ant (http://ant.apache.org/)
Apache BCEL Library (http://jakarta.apache.org/bcel/index.html)
Apache Commons Library (http://jakarta.apache.org/commons)
Apache Jakarta ORO (http://jakarta.apache.org/oro/index.html)
Apache Log4J (http://jakarta.apache.org/log4j)
Apache POI Excel Library (http://jakarta.apache.org/poi/index.html)
Apache Struts Framework (http://jakarta.apache.org/struts)
Apache Tomcat JSP/Servlet Engine (http://jakarta.apache.org/tomcat)
Apache Xerces XML Library (http://xml.apache.org/xerces2-j/index.html)
Apache Web Service related Libraries (http://ws.apache.org/)
Bouncy Castle Crypto APIs for Java (http://www.bouncycastle.org/java.html)
Direct Web Remoting (http://getahead.org/dwr)
Eclipse.org (http://www.eclipse.org)
Hibernate (http://www.hibernate.org/)
HSQL Database Engine (http://hsqldb.sourceforge.net/)
HTML Parser (version 1.6)(http://htmlparser.sourceforge.net)
HtmlUnit (http://htmlunit.sourceforge.net/)
Impression Math Expression Java parser (http://impression.sourceforge.net/)
iText PDF Library (http://sourceforge.net/projects/itext/)
Java Service Wrapper (version 3.2.3)(http://wrapper.tanukisoftware.org/doc/english/
download.jsp)
JavaAssist (http://jboss.org/javassist/)
Java Communications API (http://java.sun.com/products/javacomm/)
jregex - regular expressions for Java (http://sourceforge.net/projects/jregex)
JUnit (http://www.junit.org/index.html)
JCraft JSch (http://www.jcraft.com/jsch/index.html)
Mibble SNMP MIB parser (version 2.2)(http://www.mibble.org/index.html)
Remote Tea ONC/RPC for Java (http://www.plt.rwth-aachen.de/ks/english/remotetea.
html)
Rhino (http://www.mozilla.org/rhino/)
Quartz Scheduler (http://www.quartzscheduler.org/)
SmsJ SMS library for the Java platform (http://sourceforge.net/projects/smsj/)
Spring Framework (http://www.springframework.org)
StrutsTestCase for JUnit (http://strutstestcase.sourceforge.net/)
Subclipse plug-in for Subversion (http://subclipse.tigris.org/)
Subversion Server (http://subversion.tigris.org/)
Web Services Description Language for Java (http://wsdl4j.sourceforge.net/)
Westhawk's SNMP stack in Java (http://snmp.westhawk.co.uk)

Introduction
AppPerfect Test Manager provides web based UI for creating, managing, tracking projects,
test requirements and application bugs. It provides a central repository where projects,
requirements, tests, bugs, test results gets stored.
AppPerfect Test Manager integrates tasks such as requirement specification, test planning,
test execution, result analysis and bug tracking into one application to help you manage and
control testing of your applications. AppPerfect Test Manager is a central server where
information can be shared by all Developers, QA persons and Managers using easy to use
web based UI. It provides deep integration with various AppPerfect tools (Load Test, Web
Test, App Test, Java Code Test and Java Unit Test).
You can create various tests using AppPerfect Products where each test is desigend to test
certain requirement of your application. You can define your testing requirements in
AppPerfect Test Manager, design projects/tests to fulfill those requirements, execute or
schedule execution of those tests and analyze results of execution.

AppPerfect Test Manager Key Features
●

●

●

●

●

Supports Entire Testing Process : The AppPerfect Test Manager supports
entire testing process starting from requirements gathering and management; test/
project creation, scheduling, and executing tests; issues management; in a easy to
use Web-based UI.
Pure Web-based UI :The AppPerfect Test Manager uses a three-tier application
architecture with a pure Web-based user interface. The UI is intuitive and easy to use.
No need to install large applications or applets to be able to manage your testing
process. With only a browser and Web access, you can easily and seamlessly keep
track of your applications testing.
Informative reports :AppPerfect Test Manager provides powerful, real-time,
informative and accurate reports that help you trace problems that might be present in
the system. Reports are typically used to analyze data that spans over a period of
time. Reports can be generated as HTML, PDF, XML, CSV and XLS formats.
Scheduling of tests :You can schedule your tests with the AppPerfect Test
Manager. You do not have to be physically present to start the test. The whole
process is automated so you can schedule a test to run in the night and have a look at
the results the next day and then correct any errors found by the test.
Notification of results :You can configure AppPerfect Server to notify results
using Email or custom notification mechanism. In case of Email notification you can
specify whether you want results as attachement and AppPerfect will export the
results as HTML file and send the same as attachement with the mail.

●

Trend Analysis :AppPerfect Test Manager provides a functionality of Trend
Analysis to generate trend reports using various results of your application. This utility
takes multiple result files and generates trend charts and reports based on the data
found.

About AppPerfect Products
AppPerfect offers following products for complete and comprehensive solution for testing and
monitoring the performance of your application. These products that are designed to help you
test your application throughout the development life-cycle.

AppPerfect Java Unit Test:
AppPerfect Java Unit Test is a feature-rich wrapper for the popular JUnit and HtmlUnit testing
frameworks for non-web and web-based Java projects respectively. It provides the Java
programmer with an easy to use and fully customizable unit-testing environment, which can
be integrated with popular Java IDEs as well as the project's build process.

AppPerfect Java Code Test:
AppPerfect Java Code Test reads your software code and analyzes it for optimization, errors,
coding conventions, complexity and style based on industry-standard rules. Over 750 predefined, high-value rules can be applied to your code. AppPerfect Java Code Test is an ideal
tool to perform code reviews on an on-going basis to ensure high quality of code.

AppPerfect Java Profiler:
AppPerfect Java Profiler profiles a Java Virtual Machine to assist you in understanding the
behavior of your application as it performs its functions. AppPerfect Java Profiler recognizes
that your application does not operate in a vacuum and hence provides a unique blend of
Java information combined with operating system information.

AppPerfect App Test:
AppPerfect App Test performs regression and functional testing of your Windows/Desktop
applications. Performing manual functional testing by having a person sit and manually click
away at the application is extremely expensive and error-prone. AppPerfect App Test
provides the means to perform such labor-intensive activity in an automated manner.

AppPerfect Web Test:
AppPerfect Web Test performs regression and functional testing of your Web applications.

Performing manual functional testing by having a person sit and manually click away at the
application is extremely expensive and error-prone. AppPerfect Web Test provides the means
to perform such labor-intensive activity in an automated manner.

AppPerfect Load Test:
AppPerfect Load Test is a stress/load testing tool that can simulate hundreds of virtual users
from a single machine. Features supported include site recording, dynamic variable
substitution, cookies support, session tracking, SSL support and run strategies. It can run
tests based on a variety of strategies such as burst, incremental, exponential, quadratic or
loop. It also provides you a comprehensive solution to monitor various attributes of various
operating systems present in your application infrastructure.

AppPerfect Test Manager:
The AppPerfect Test Manager is central server with a Web-based UI for accessing various
modules in the server. AppPerfect Test Manager consists of five main modules:
Requirements Manager: This module is used to create requirement specifications
around which your tests will be designed and executed. Functional, business, performance,
technical and usability requirements should be defined here to ensure the tests cover all
defined criteria.
Test Manager: Once tests have been designed, the Test Manager can be used to manage
the execution of your tests. Automatically running tests on a specific schedule, notification of
test results, saving of test results, etc. can be defined in this module.
Results Manager: Once results for your various tests have run a few iterations, the
Results Manager can be used to manage the archived results. Trend Analysis of multiple
results to detect key quality trends is a key feature of this module. Storage management can
also be performed via this module.
Issues Manager: As tests are run, issues such as defects, enhancements, modifications,
etc. will occur. This module can be used to create and track such issues. This module is
designed as a light-weight issues manager that seamlessly integrates with the rest of the
server and is not intended to replace full-featured issues management system.
License Manager: Floating/site licenses are managed using this module. This module
acts as the central manager for issuing and reclaiming floating licenses for the AppPerfect
products.

AppPerfect Agentless Monitor:

The AppPerfect Agentless Monitor is an agentless, Web-based monitoring solution. It helps
you monitor your applications and the underlying system resources. The AppPerfect
Agentless Monitor consists of:
AppPerfect Monitor: A pure Web-based solution that helps you monitor your application
infrastructure. Provides a rules engine to define alerts: a notification server for email and SMS
notifications. Also includes a powerful report designer to create custom reports to analyze and
understand the performance data.
AppPerfect Monitors: A series of modules designed to support specific devices.
AppPerfect Monitor does not use the traditional agents-based approach to monitoring. Apart
from being expensive, agents-based approach is also highly complex and error-prone.
AppPerfect Monitors are designed to impose negligible overhead on the monitored system.
These monitors are superbly optimized programs providing the maximum amount of
information while imposing the lowest possible overhead.
Currently, the following devices are supported:
●
●
●
●
●
●
●

Java/J2EE App Servers (Tomcat, WebLogic, WebSphere, etc.)
Operating Systems Resources (Windows, Linux, Mac OS X)
Databases (Oracle, MySQL, MS SQL, DB2, Sybase)
Web Servers (Apache HTTP Server, MS IIS)
SNMP Monitors (v1 and v2)
Ping Monitor (Device heartbeat monitor)
Mail Server (MS Exchange)

About AppPerfect Corporation
AppPerfect Corporation is an independent software development company dedicated to
providing the developer community with the best-in-class tools throughout the entire software
life-cycle. Our aim is to be your primary vendor for most of your development- and
deployment-tool needs. Our mission is to help you reduce your software development costs,
increase your productivity and help improve the availability and scalability of your
applications. Please visit us on the Web at www.AppPerfect.com for more information.

Getting started
This guide assumes you have successfully installed the AppPerfect Test Manager. This guide
also assumes that you are the administrator for the AppPerfect server and have the password
for the 'administrator' user.

Logging Into the Server
Launching AppPerfect Test Manager is a two-step process: starting the server and log on to
it. By default Test Manager gets installed as service for admin/root users. Non-admin users
needs to start server manually using the links provided.
For Windows
1. Click Start -> Programs -> AppPerfect Test Manager XXX -> AppPerfect
Services -> Start.
2. Once server starts, click Start -> Programs -> AppPerfect Test Manager
XXX -> AppPerfect Test Manager Login. Use 'administrator' as user name
and the password specified during installation to log on to the Test Manager.
For Linux and Solaris
1. Open the shortcuts folder AppPerfect_Test_Manager_XXX/
AppPerfect_Services and double-click Start.
2. Open the shortcuts folder AppPerfect_Test_Manager_XXX and double-click
AppPerfect_Test_Manager_Login. Use 'administrator' as user name and the
password specified during installation to log on to the Monitor server.

Using the documentation
You may invoke the help system from anywhere in the AppPerfect Test Manager Console UI.
Additional notes on documentation:
Printable versions of the documentation are shipped along with the product. Go to Start ->
Programs -> AppPerfect Test Manager XXX -> Documentation -> Print
Manuals folder to invoke the PDF versions of the guides. Note that the print manuals, like all
other parts of this software product, are subject to the AppPerfect Software License
Agreement.

Getting product support
If you need additional assistance with our products, please contact AppPerfect at the email
address specific to your query:
Sales: sales@AppPerfect.com
Support: support@AppPerfect.com
Online Technical support (FAQs, Tips, Tutorials, Docs): AppPerfect Test Manager
Comments and suggestions
The AppPerfect Development Group welcomes and appreciates your comments and
suggestions. Please send all comments/suggestions at our direct email address at:
support@AppPerfect.com

User Guide
AppPerfect Test Manager is divided into seven sections:
●

Projects: Define your application.

●

Requirements: Define requirements for your application.

●

●

Tests: Define tests for your application. Tests can be created using AppPerfect
Products or any other product.
Schedules: Schedule your tests to execute at any time with variety of options.

●

Bugs: Define bugs in your application and track them till they are fixed.

●

Results: Save results of AppPerfect Tests on execution and analyze these results and
generate various reports.
Reports: Provided large no of pre-defined reports for all sections and specialized
reports for analyzing AppPerfect test results & trend analysis.

●

Projects
Your project is a central point in AppPerfect Test Manager. This section allows you to define
your application. Create a project with as much details as possible. Define each and every
component of your application. Define your team members, project leader. You can define
each and every version & builds created of your application here. You can define various
keywords for your application. These keywords are helpful in searching your project.

Add project
To add a project, simply select Add button. You will see a wizard with default values.

Edit project
To edit an existing project, select the checkbox and select Edit button. You will see a wizard
with all field populated with existing values.

Project wizard
You will see this wizard when you add/edit a project. Project wizard has two tabs viz; General
and Components. In General tab, Please provide project name, description, current status,
team members etc. of project in this tab. You can upload all files related to your application
viz; design document, project schedule etc. Please select if you want to allow users to add

requirements & bugs for this project. Please configure voting related information as well here.
Maximum Votes per bug is a value a person can put on a single bug. It should be some
number lower than the "Maximum votes per person". Don't set this field to "0" if "Maximum
votes per person" is non-zero.
Votes to confirm: is number of votes a bug in this project needs to automatically get out
of the UNCONFIRMED state. Setting this field to "0" disables the automatic move of bugs
from UNCONFIRMED to NEW.
In Components tab configure all the project components, versions and builds of your
application. You can define various milestones of your application in this tab. You can define
keywords of your application.

Delete project
To delete projects, select the checkbox of all the projects you want to delete and select
Delete button. You will get a confirmation message which when accepted will delete all the
selected projects. Note: Deleting a project will also delete all its requirements, tests, bugs
etc. You can instead mark a project as "inactive".

View project
A project name in the list is link to view project details. You can view project details in this
single view.

Requirements
You can define all requirements of your application in this section. You can define various
keywords for your requirement. These keywords are helpful in searching your requirement.
You can define detailed steps & notes of a requirement.

Add requirement
To add a requirement, simply select Add button. You will see a wizard with default values.

Edit requirement
To edit an existing requirement, select the checkbox and select Edit button. You will see a
wizard with all field populated with exisiting values.

Requirement wizard
You will see this wizard when you add/edit a requirement. Requirement wizard has two tabs
viz; General and Details. In General tab, Please provide requirement name, description,
current status, prioriy, severity etc. of requirement in this tab. You can upload all files related
to requirement. You can track all the changes of a requirement by selecting "Store history of
changes made to the requirment". Associate the requirement wih the project, component,
version, build & milestone.
In Details tab define detailed steps of a requirement and additional notes of a requirement.
You can define keywords of your requirement in this tab.

Delete requirement
To delete requirements, select the checkbox of all the requirements you want to delete and
select Delete button. You will get a confirmation message which when accepted will delete all
the selected requirements.

View requirement
A requirement name in the list is link to view requirement details. You can view requirement
details in this single view.

Tests
Based on requirements defined for a project, testing team can start building the actual test
cases. Test Manager is tightly integrated with various AppPerfect Products such as Load
Tester, Functional Tester, Code Analyzer and Unit Tester etc. When a test gets created in
these products it gets reflected in Test Manager immediately. Testers can then link the
generated test with a requirement to reflect that particular requirement has been covered.
Testers can also create there own tests in order to cover requirements of project
Once all tests are designed and all requirements of an application are addressed, the testing
team can start running the tests. Test Manager provides functionality to schedule tests to run
unattended, overnight etc. You can also schedule a test to run on build finish, when build
finishes you need to invoke URL to execute the scheduled Job. Test Manager allows to
configure various properties with scheduled as well as manual test runs like whether to send
notification or not, on which machine to run test etc.

Add test
To add a test, simply select Add button. You will see a wizard with default values.

Edit test
To edit an existing test, select the checkbox and select Edit button. You will see a wizard with
all field populated with exisiting values.

Test wizard
You will see this wizard when you add/edit a test. There are two types of tests viz; Created
manually and those created in AppPerfect Products. Tests created using AppPerfect products
can be tightly integrated by providing more details. Test wizard has two tabs viz; General and
Details. In General tab, Please provide test name, description, current status etc. of test in
this tab. For manually created tests, you can upload all files related to test. Associate the test
with a project. You can link manually created tests to requirements of associated project. You
can link tests created in AppPerfect products to requirements of associated project. In this
case, requiremens can be further linked to groups/packages of AppPerfect Tests.
In Details tab define steps of the test, test notes. You can define keywords of your tests in this
tab.

Delete test
To delete tests, select the checkbox of all the tests you want to delete and select Delete

button. You will get a confirmation message which when accepted will delete all the selected
tests.

View test
A test name in the list is link to view test details. You can view test details in this single view.

Schedules
This section allows you to schedule Tests defined in Test Manager. A test created can be
setup to execute at a given date and time. This feature enables tests to be carried out at any
time that is suitable to you. For example, the test can be scheduled to run at night and results
can be analyzed the next morning.

Add schedule
To add a schedule, simply select Add button. You will see a wizard with default values.

Edit schedule
To edit an existing schedule, select the checkbox and select Edit button. You will see a
wizard with all field populated with exisiting values.

Schedule wizard
You will see this wizard when you add/edit a schedule. A scheduled test is referred to as a
job. Enter the name of the job in the Job Name field. This will be saved as a unique value in
the scheduler server and can be edited or deleted from the list of jobs that appear in the table
underneath. The specified Job Name must not contain \ /:;*?"<>|or blank space. Select the
Test to schedule. If the selected test is AppPerfect Test, you can choose to run the test in UI
or Non UI option depending on the mode you want the application to execute at the
scheduled time.
Frequency
Once Only: Tests scheduled with Only Once option selected, run only once at a user
specified time and date. To schedule a test to be run on a only once, select Once Only option
in the combo box. Set the time and date for execution of the test using the date time selector
dialog. In this option, you can repeat he job o run after some interval. Tests scheduled with
this option selected, run after every X time user has specified. Set the time in hours and
minutes after which you want to repeat the process.
Daily: Tests scheduled with daily option selected, run daily at a user specified time and date.
To schedule a test to be run on a daily basis select Daily option in the combo box. Set the
time and date for execution of the test using the date time selector dialog
Weekly: Tests scheduled with Weekly option selected, run at the user specified time and on
the days selected from the start date selected. To schedule a test to be run on a weekly basis

select Weekly option in the combo box. Set the time and date for execution of the test using
the date time selector dialog. Select check boxes corresponding to the days of the week.
At the end of build process: This option should be selected when you want to run this
job on finish of your build process. The "Build Finished" event should to be fired from your
build process. To fire "Build Finish" Event please send an HTTP request (URL):- http://
hostname:8744/AppTestManager/ScheduledJob.execute?jobname=xxx where xxx is the
name of the job.
A the end of another scheduled job: This option should be selected when you want to
run this job on finish of some other scheduled job. This is useful if you want to run multiple
tests one after another based on status of previous project.
You can configure notifications to be sent. If the scheduled test is AppPerfect test, you can
specify whether to save result, export result. etc after the execution or not.

Delete schedule
To delete schedules, select the checkbox of all the schedules you want to delete and select
Delete button. You will get a confirmation message which when accepted will delete all the
selected schedules.

View schedule
A schedule name in the list is link to view schedule details. You can view schedule details in
this single view.

Bugs
This section allows to manage bugs present in your application. After analysis of results
testers can add bugs present in the application which can then be viewed by developers,
managers etc to take decision on deployment of application. Test Manager tracks entire
lifecycle of a bug from creation through fixing and verifying the fix. This allows to ensure that
all bugs are addressed before product is deployed or released.

Bugs
Bug is a core part of this section. While adding a bug, you have to specify name of the bug
and a brief summary of a bug. You can describe the bug in description field. You also need to
select appropriate status, severiy, priority of the bug. When the manager views the list of
bugs, manager can assign it to any of the developers and the date on which it was assigned.
Developers can then fix the issue and update the status of the bug. Testers will then recheck
the existence of the bug in the product and update the status of the bug. This way the Test
Manager keeps track of the complete life cycle of the bug. If you select "Store history of
changes made to the bug", you will be able to track the changes made to the bug through out
its life cycle.

Add bug
To add a bug, simply select Add button. You will see a wizard with default values.

Edit bug
To edit an existing bug, select the checkbox and select Edit button. You will see a wizard with
all field populated with exisiting values.

Bug wizard
You will see this wizard when you add/edit a bug. Bug wizard has two tabs viz; General and
Project. In General tab, Please provide bug name, description, current status etc. of bug in
this tab. You can link bugs to tests of associated project.
In Projects tab select the project for which this bug is added. You can also associate a project
component, version and build for this bug. You can upload all files related to bug in this tab.
You can define keywords of your tests in this tab.

Delete bug
To delete bugs, select the checkbox of all the bugs you want to delete and select Delete

button. You will get a confirmation message which when accepted will delete all the selected
bugs.

View bug
A bug name in the list is link to view bug details. You can view bug details in this single view.

Results
This section shows the results saved by executing AppPerfect Test to Test Manager. It shows
summary result of test execution and provides option to view complete result in HTML format
and to send this HTML report as an attachment to users.

View result
To view a detailed report of the test execution, select the checkbox and select View button.
You will see a report in a new window.

Send result
To send detailed report of the test execuion, select the checkbox and select Send button.
Provide the details for sending the mail and select Send button.

View summary
A test name in the list is link to view execution summary. You can view execution details in
this single view.

Reports
AppPerfect Test Manager provides lots of System reports. These are predefined report
designs that are shipped with AppPerfect, user can filter data shown in these reports based
on his requirements. Each report can be exported into HTML, PDF, XLS, CSV and XML
formats. The list also includes trend analysis reports.

Generate report
To generae a report, select the radio button and select Generate button. You will get a view
containing required filters for the selected report.Select the format in which you want to export
the report and select Generate button.

Administration
This chapter provides useful information on the various options that the AppPerfect products
offers so that you can setup your environment conveniently and select the settings that best
suits your requirements. This view is available only for user having admin privilege.
This chapter has following sections:
●

License settings

●

User settings

●

Requirement settings

●

Bug settings

●

Project settings

●

Test settings

●

Database settings

●

Notification settings

●

Keyword settings

License settings
Here you can configure license settings for AppPerfect products. If you want to use floating or
concurrent license for AppPerfect Products, you should update license key here. In case of
Desktop license for AppPerfect Products its not required to update license key here. Also
AppPerfect Test Manager license key should be updated from here.

User settings
This view shows list of users configured in Test Manager. To add a user, simply select the
Add button. To edit an existing user, select the radio button and select Edit button.

Requirement settings
In this view, you can configure Requirement Status, Priority and Severity. You can add/edit/
delete them in this view.

Bug settings

In this view, you can configure Bug Status, Priority, Severity and Resolution. You can add/edit/
delete them in this view.

Project settings
In this view, you can configure Project Status. You can add/edit/delete it in this view.

Test settings
In this view, you can configure Test Status. You can add/edit/delete it in this view.

Database settings
Here you can configure database for AppPerfect Test Manager. It provides a default HSQL
server, bu user can migrate to any database supported by Test Manager. In order to change
the database, you will require to copy a jar containing the JDBC driver class that you specify
below to WEB-INF\lib directory. Change and update the database settings. On successful
modification of settings, you will be notified to restart the server. Please stop the server, copy
the jar to WEB-INF\lib directory and restart the server. AppPerfect Test Manager provides jar
for HSQL database, hence you need not copy this jar.

Notification settings
The AppPerfect Products can be configured to provide notifications in a variety of mediums:
You can get notifications about a test result through email or to custom program.
The configuration of this feature involves providing sender details and recipient details. You
can use all the notification media or some of them or none of them, as per your requirement.
Configuration of all these options is quick and easy. Notification is sent on the completion of
the replaying of the test.

Email
To enable Email Notifications, first select the checkbox 'Enabled'. Now you can proceed with
the following settings:
Sender Settings
Name: Here, enter the name of the sender. This can be any name, and does not have to
match the one associated with an email id. The field accepts all characters, there's no
restriction on what can be entered in the field.

Email Address: Here, enter the email address of the sender. This must be a valid email
address.
SMTP Server: Enter the SMTP server of the email sender. This must be a valid server. You
can enter here the SMTP server name or IP address. Only enter one SMTP server here.
Authentication Required: Select this option if the SMTP server requires authentication.
This is true in most cases as you will most likely have an account on the smtp server with a
user name and password. Provide those details in the 'Username' and 'Password' fields that
follow.
Recipient IDs
Email ID: Here, just provide the email Ids of the recipients. There is no limit on the number
of recipients to be added..

Custom
If you want to use custom notification then you can specify the path of exe or bat file which
should be called when application wants to send notifications.

Keyword settings
In this view, you can configure all the keywords used in Test Manager. You can add/edit/
delete the keywords in this view.

Automated Software Test Management System
This tutorial provides a brief introduction to the various features of the AppPerfect Test
Manager using a set of hands-on practice exercises. To complete few of the exercises we
need a client product from AppPerfect, for this tutorial we will use AppPerfect Load Test. This
tutorial assumes you have successfully downloaded and installed AppPerfect Test Manager
and AppPerfect Load Test on your machine with the default options. Apart from this prerequisite, this tutorial is self contained. Instructions given below are Windows-specific; if you
are using a non-Windows machine, please use equivalent commands/instructions.
This document is divided into various sections:
●

AppPerfect Test Manager
1. Login to Test Manager (web interface)
2. Creating User Project
3. Creating Test Requirements

●

AppPerfect Load Test
1. Configuring AppPerfect Load Test with AppPerfect Test Manager
2. Creating Project
3. AppPerfect Load Test

●

Both
1. Linking AppPerfect test with a project
2. Linking requirements with AppPerfect test
3. Auto-updation of requirement status on project execution

Within each section, multiple exercises are listed. Each exercise forms a logical unit which is
expected to take no more than a few minutes to perform. All exercises use the PetStore demo
application running inside Apache Tomcat. The modified PetStore application and Tomcat are
both bundled with AppPerfect Load Test product.
All exercises assume you have installed AppPerfect Test Manager product in C:
\AppPerfect\TestManager folder and AppPerfect Load Test product in C:\AppPerfect
\LoadTest folder. The install location of Test Manager will be referred as
TESTMANAGER_HOME and install location of Load Test will be referred as
LOADTEST_HOME henceforth in tutorial. If you have installed the products in some other
folders, modify the instructions below appropriately.
This tutorial is not intended as a comprehensive training guide. Please refer to the product
documentation for detailed information. However, this tutorial will give you a very good

overview of the products and substantially improve your productivity with the product.

Login to Test Manager (web interface)
By default AppPerfect Test Manager is configured to run as a service, hence it will start when
the OS starts and stops when OS shuts down. However, server can be started/stopped
manually using Start -> Programs ->AppPerfect Test Manager -> AppPerfect Service ->
Start / Stop respectively. you can verify that the server is running by selecting Start ->
Programs -> AppPerfect Test Manager Login. This should start a browser and fire a URL
http://localhost:8744/AppTestManager which will show you a Login page.

Exercise 1: Login to Test Manager
Action:- On Windows
1. Launch the web interface using Start -> Programs -> AppPerfect Test Manager x.x.x > AppPerfect Test Manager Login
2. A Browser window will open with the fields 'Username' and 'Password'.
3. When the server is installed, there exists one super user "administrator". Enter the
username as administrator. The password of this user is provided by you during
installation of the server. Enter the password in password text field. Click on Login
button.
4. On successful login in to the server, you will see dashboard view. You are advised to
view all the links to have a fair idea of the features provided by AppPerfect Test
Manager.
Action:- On Linux
1. Launch the web interface using by opening the shortcuts folder
AppPerfect_Test_Manager and double-click AppPerfect Test Manager
Login
2. A Browser window will open with the fields 'Username' and 'Password'.
3. When the server is installed, there exists one super user "administrator". Enter the
username as administrator. The password of this user is provided by you during
installation of the server. Enter the password in password text field. Click on Login
button.
4. On successful login in to the server, you will see dashboard view. You are advised to
view all the links to have a fair idea of the features provided by AppPerfect Test
Manager.

Creating User Project
Here you can configure project for which you want to use AppPerfect products. For the
purpose of tutorial we will use the built-in PetStore web application. You can specify Build,
Version etc. of of your project which you want to test.

Exercise 1: Create User Project
1. Select Projects link from top navigation bar.
2. Click on Add button, you will see a wizard like screen where you can add required
details about your project/application.
3. Enter PetStore as your project's name. Enter summary and description as Test
Manager tutorial using PetStore. Please select the checkbox Allow users to add Bugs
for project & Allow users to add Test Requirements for project as we will be adding
test requirements to our PetStore project.
4. Provide other details if you wish and click on Next button.
5. Each project can have multiple modules/components. One can specify Project
Components in this step.
6. Select Add button in Components row. A form will come up in the same row.
7. Enter Login as the component name & in description enter This components tests
Login module of PetStore application.
8. Select Save. You will find Login row present in component's table. Similarly add Cart
Operations and Check Out components to the project.
9. Verify the entries added and finally on Finish button.
10. You will be taken back to Projects list view and you will see just added project in the
list. You will also get an info message PetStore created successfully. below
navigation bar.
11. You can view details of project by clicking on project name link.

Creating Test Requirements
Before we perform load testing on this PetStore application we will define certain test
requirements.

Exercise 1: Adding Requirements
1. Select Requirements link from top navigation bar.
2. Click on Add button, you will see a wizard like screen where you can add required
requirement details.

3. Enter the requirement name as Login and select its status as "Open".
4. In the project combo box (6th row from top) select PetStore. In the same row, next
column we have project component. By default a requirement is not associated to any
project component. In that combo, select Login.
5. Provide appropriate summary and details of this requirement. We should provide as
much details as possible for this requirement. Now click on Next button and finally on
Finish button.
6. You will be taken back to Requirements list view and you will see just added
requirement in the list.
7. Similarly add two more requirements say Add Birds to Cart and Purchase birds under
Cart Operations and Check Out groups respectively.
8. You can view details of requirement by clicking on requirement name link.
Now we will move to AppPerfect Load Test application to create a project so that it meets our
requirements. We will come back to linking these requirements with the groups in the project
once it is saved to server database.

Configuring AppPerfect Load Test with AppPerfect Test Manager
In AppPerfect Load Test, you can integrate reports & results management feature provided
by AppPerfect Test Manager by providing Test Manager settings.

Exercise 1: Launch AppPerfect Load Test
1. Click on Start -> Programs ->AppPerfect Load Test x.x.x -> AppPerfect Load Test
2. On launching AppPerfect Load Test a Workspace Launcher dialog will be shown.
Please leave the default value and select the check box "Use this as the default and
do not ask again". Click OK to continue.
3. On start of product AppPerfect Load Test a Welcome page will be displayed. Go
through the brief description given for product
NB: Welcome page is displayed only when Load Test x.x.x is launched first time and
when last time no project was opened.

Exercise 2: Specifying Test Manager settings
1. Launch the Preferences dialog by clicking Tools ->Options... menu option. The
Preferences dialog will be launched with Load Test node selected in the tree.
2. Select Server Connection node. Here you can configure Test Manager settings,
Repository settings and built-in service settings. We will configure Test Manager

settings.
3. Select the checkbox Use Test Manager for Reports/Results management. This will
enable UI elements present in the next row. In the second text field enter the host
name or IP address on which Test Manager is installed and running. Since for this
tutorial its running locally, we will provide localhost. In the third text field provide 8744.
4. Select Validate Settings button next to it. If the settings are proper, it will show a
message Test Manager information provided is correct.

Creating Project
Exercise 1: Creating a Project
1. Launch the Project Wizard by clicking File ->New... menu option. The New Project
wizard will be launched.
2. Keep the default project name and location for the purpose of this exercise. We don't
have to provide "Notification" settings. Click on the OK button.
3. A confirmation message saying that the project is saved will be displayed. Click on the
OK button.
Now using this Project we will create tests to demonstrate the functionality of AppPerfect
Load Test for Web Applications

AppPerfect Load Test
NB: Please follow the steps provided in the Creating Project section to first create a Project,
then proceed further.

Exercise 1: Define a Load Test project
1. Once the Project is successfully created another dialog "Define Project Properties" will
be displayed.
2. Keep the default settings as shown in this dialog i.e., Test Duration:1min, Run Type:
Burst, Virtual Users:10.
3. Go through the description given for Burst run type at the bottom.
4. Review other settings in the Panel and click on the OK button to close this dialog.
5. Click through all the menu items to familiarize yourself with the available features and
how to access them. Viewing through all menu items will give a reasonable overview

of the application.
6. Click Help -> Table of Contents menu item to see AppPerfect Load Test product
documentation
7. Open the Preferences dialog by selecting the menu option Tools -> Options...
8. Review the default settings for Load Test and click the OK button to close the dialog.

Exercise 2: Recording a Test
The empty project has three groups viz; StartingGroup, ActionGroup1 and EndingGroup.
These groups are intended to provide categorization of tasks as per the nature of the group.
As the names suggest, while performing any task online it typically involves startup actions
like Login in to the server, etc. Then you perform some actions like buy, sell, view etc and
finally you logout from the server. It is a good idea to record the startup actions in
StartingGroup, all your actions in ActionGroup1 and final action of Logout in EndingGroup.
The advantage of doing this are many, but the most significant one is, when the test is
replayed for a certain duration (say 1 minute), at the end of this duration Load Test will stop
executing the subsequent tasks, instead it will complete tasks in that group and then execute
the EndingGroup before stopping the test. This ensures that a configured user is not left
logged into the server which may cause security issues.
AppPerfect Load Test comes with a built-in tomcat server containing PetStore web
application. We will record tests such that actions up to Login are recorded in StartingGroup,
buying of pets is done in ActionGroup1 and finally user is logged of in EndingGroup.
1. Start tomcat server by selecting Start->Programs->AppPerfect Load Test x.x.x>Documentation and Examples->Examples->Tomcat running PetStore->Start Server.
2. To start recording, click on Project -> Record test... in the menu bar.'
3. 'Record a test' dialog will be displayed. Select StartingGroup1 from the Group combo.
Provide starting URL as "http://localhost:8396/petstore". In Authentication drop down
select "HTML Form based Login". Specify Username as "j2ee" and passowrd as
"j2ee". Click on 'Start recording' button to start recording test.
4. An instance of Microsoft Internet Explorer will be launched with the PetStore home
page loaded. Click on enter the store link. This will populate the database and
display the PetStore main page. Note that populating the database might take some
time.
5. Click on Sign-in link located at top-right.
6. This will bring up a page through which you can login if you are already signed up as a
customer. Select "Submit" in the first group.
7. Now go back to recording dialog and change the group to ActionGroup1.
8. Click on each link on the left: Birds, Reptiles, Dogs, Cats, Fish
9. Order an item by clicking on: Birds -> Amazon Parrot -> Adult Male Amazon Parrot ->
Add to cart
10. Now go back to recording dialog and change the group to EndingGroup.

11. Check out by clicking on the Check Out link and place the order
12. Sign out of PetStore by clicking on Sign-out at top right of screen.
13. Close browser by clicking on File -> Close in the browser window.
14. Click on the Stop button of "Record a test" dialog to stop the recording session.
15. Click on Close button to close the 'Record a test' dialog.
16. The URLs navigated will be displayed under StartingGroup, ActionGroup1 and
EndingGroup.
17. Click through each Tasks to view its details on the panel on the right.

Exercise 3: Saving this test in Test Manager
1. To save the test with Test Manager, click on File -> Save in Test Manager from the
menubar.
2. You will get a message "Project saved in Test Manager.

Linking requirements with tests/groups
Exercise 1: Link Login Requirement with StartingGroup of PetStore project
1. Launch the web interface using Start -> Programs -> AppPerfect Test Manager ->
AppPerfect Test Manager Login. You we see a login page where in you can provide
the username & password.
2. When the server is installed, there exists one super user "administrator". Enter the
username as administrator. The password of this user is provided by you during
installation of the server. Enter the password in password text field. Select Login
button.
3. On successful login in to the server, you will see dashboard view.
4. Select Tests link from top menu. You will see NewProject entry present in the list.
5. Select the checkbox besides the Test. This will enable Edit button. Select Edit button
6. Select PetStore from the project combo box (4th row from top). This will enable New
Link Requirement below it.
7. Select "New Linked Requirement" button. A link requirement form will be seen in the
same row.
8. Select Login from the requirement combo box.
9. Select StartingGroup and press ">>" button to move the selected group to right hand
list.
10. Select Save to linked requirement.
11. Once again select "New Linked Requirement" button. A link requirement form will be
seen in the same row.

12. Select Add Birds to Cart from the requirement combo box.
13. Select ActionGroup1 and press ">>" button to move the selected group to right hand
list.
14. Select Save to linked requirement.
15. Once again select "New Linked Requirement" button. A link requirement form will be
seen in the same row.
16. Select Check Out from the requirement combo box.
17. Select EndingGroup and press ">>" button to move the selected group to right hand
list.
18. Select Save to linked requirement.
19. We have linked all our 3 requirements with 3 groups of Load Test test. Select Next
and finally select Finish.
20. You will be taken back to Test list view. You will also get an info message
NewProject saved successfully. below navigation bar.

Exercise 3: Executing a test
1. To execute the test, click on Project -> Run from the menubar.
2. The focus will be shifted to Status tab. Here the current status of the test execution will
be displayed. Various test metrics such as response time, virtual user count, etc. are
continuously refreshed in the charts.
3. The test will run for 1 minute as specified when project was created.
4. Stop running tomcat server by selecting Start->Programs->AppPerfect Load Test x.x.x>Documentation and Examples->Examples->Tomcat running PetStore->Stop Server.

Exercise 4: View and analyze result. Save result to database (Test Manager database)
1. Once the test is completed, the test results will be displayed in the "Results" tab and
result summary data is displayed in the main window on the right.
2. Since no error was detected during our test execution, the result of our test execution
was "Successful". Additional details about hit count, etc. is also displayed.
3. View various result summaries by clicking on the items in the tree on the left in the
Results tab
4. We should save the test execution results to Test Manager database for further report
& results management. To save the result to database, click on File -> Result -> Save
in Database from the menubar. You will get a message "Result saved in database".

Auto-updation of requirement status on project execution

Exercise 1: Check auto updation of requirement status in Test Manager on execution
of test in AppPerfect Load Test
1. We already have LoadTest open and NewProject open in it. If not, perform next 2
steps.
2. Click on Start -> Programs ->AppPerfect Load Test x.x.x -> AppPerfect Load Test
3. This will open the earlier project NewProject
4. Start tomcat server by selecting Start->Programs->AppPerfect Load Test x.x.x>Documentation and Examples->Examples->Tomcat running PetStore->Start Server.
5. To execute the test, click on Project -> Run from the menubar.
6. Once the test is completed, the test results will be displayed in the "Results" tab and
result summary data is displayed in the main window on the right.
7. We should save the test execution results to Test Manager for further report & results
management. To save the result to Test Manager, click on File -> Result -> Save in
Test Manager from the menubar. You will get a message "Result saved in Test
Manager".
8. Launch the web interface using Start -> Programs -> AppPerfect Test Manager ->
AppPerfect Test Manager Login. You we see a login page where in you can provide
the username & password.
9. When the server is installed, there exists one super user "administrator". Enter the
username as administrator. The password of this user is provided by you during
installation of the server. Enter the password in password text field. Select Login
button.
10. On successful login in to the server, you will see a dashboard view.
11. Select Requirements link from top navigation bar.
12. View the status of all the Requirements we added. It would have been changed to
"RESOLVED" as our project executed successfully without any task failures.

Concluding Remarks
We greatly appreciate your effort in completing this tutorial. We hope it has given you a good
overview of the various products and their features. While it may seem a lot, going through
this tutorials a couple of times will give you a solid footing not only with the software but also
with the underlying functional concepts of software testing.
There were a lot of features which were not covered by this tutorials, including
1. Scheduling
2. Notifications
3. Report generation

4. Bugs management
5. Administration
Please refer to the product documentation for additional details on all product features.
We are always eager to hear your feedback regarding the product, the documentation, the
tutorial or any other issue related to the product. Please provide us your feedback at support
(at)AppPerfect.com.
Thank you.
AppPerfect Support

