Functional Testing a Windows Application

This tutorial provides a brief introduction to the AppPerfect App Test product using a set of hands-on practice exercises. This tutorial assumes you have successfully downloaded and installed AppPerfect App Test on your machine with the default options. Apart from this pre-requisite, this tutorial is self contained.

This document is divided into following sections

  1. Creating Project
  2. AppPerfect App Test

Within each section, multiple exercises are listed. Each exercise forms a logical unit which is expected to take no more than a few minutes to perform. All exercises use the Notepad application available under "C:\WINDOWS" or "C:\WINNT" folders.

All exercises assume you have installed the product in C:\AppPerfect\AppTest folder and will be referred as AppTest_HOME henceforth in tutorial. If you have installed the product in some other folder, modify the instructions below appropriately.

This tutorial is not intended as a comprehensive training guide. Please refer to the product documentation for detailed information. However, this tutorial will give you a very good overview of the products and substantially improve your productivity with the product.

Creating Project

Exercise 1: Launch AppPerfect App Test

  1. Click on Start -> Programs ->AppPerfect App Test x.x.x -> AppPerfect App Test
  2. On launching AppPerfect App Test a Welcome page will be displayed. Go through the brief description given for product.
    NB: Welcome page is displayed only when App Test x.x.x is launched and last time no project was opened.

Exercise 2: Creating a Project

  1. Launch the Define New Project Dialog by clicking File ->New... menu option. The New Project wizard will be launched.
  2. Keep the default project name and location for the purpose of this exercise. Click on the OK button.
  3. A confirmation message saying that the project is saved will be displayed. Click on the OK button.

Now using this common project we will create tests to demonstrate the functionalities of AppPerfect App Test product.

AppPerfect App Test

NB: Please follow the steps provided in the "Creating Project" section to first create a project, then proceed further.

Exercise 1: Define a App Test project

  1. Once the common project is successfully created another dialog - Define Project Properties dialog - will be displayed.
  2. The dialog shows various options which can be configured for the project, leave them default and click on OK button.
  3. Click through all the menu items to familiarize yourself with the available features and how to access them. Viewing through all menu items will give a reasonable overview of the application.
  4. Click Help -> Table of Contents menu item to see AppPerfect App Test product documentation
  5. Open the Preferences dialog by selecting the menu option Tools -> Options...
  6. Review the default settings for App Test and click the OK button to close the dialog.

Exercise 2: Recording a Test

  1. To start recording, click on Project -> Record test... in the menu bar.'
  2. 'AppPerfect Recorder' dialog will be displayed. Select ActionGroup1 from the Group combo and provide proper executable path as "C:\WINDOWS\notepad.exe" or "C:\WINNT\notepad.exe" depending on the path on your machine. Now Click on 'Start recording' button.
  3. An instance of Notepad Application will be launched.
  4. Type text "Hello" in the edit box of Notepad.
  5. Click on Menu "Help > About Notepad", click on OK button.
  6. Type text ", to AppPerfect App Test" after "Hello" in the edit box.
  7. Now click after "," and type "Welcome " in the edit box.
  8. Close Notepad application using Menu option "File>Exit". A dialog asking do you want to save changes will be shown, click on "NO" in this dialog. .
  9. Click on the Stop button of "AppPerfect Recorder" dialog to stop the recording session.
  10. Click on Close button to close the 'AppPerfect Recorder' dialog.
  11. In the AppPerfect App Test window, look at the tree on the left. Each action you performed has been recorded.
  12. Click on any of the recorded action on the left. The image of the window associated with that action is displayed on right hand frame. You can also find element/event details and recorded window properties/attributes there

Exercise 3: Executing a test

  1. To start replay of the recorded test, click on Project -> Run from the menu bar.
  2. An instance of Notepad Application will be launched and each of the recorded events is replayed. No manual intervention is required during test replay, unless an error is encountered.

Exercise 4: View and analyze results

  1. After replay, results are displayed in Results tab located at the top left of the window.
  2. Click on Results tab. Test results details are displayed on the right. Click on individual items in the tree on the left to view details on specific actions.
  3. Browse and examine the different views that are displayed on selecting the various nodes in the navigation tree.
  4. Select the Action Group node. This report gives a summary of the successful, failed, timed-out & not played Events & Windows.